De afgelopen jaren is de ontwikkeling van PHP op server niveau flink doorontwikkeld. We hebben verschillende PHP versies langs zien komen in de afgelopen jaren. Denk hierbij aan: PHP 5.6, 7.0, 7.3, 7.4. Momenteel zijn we alweer aangekomen bij PHP 8.0 en PHP 8.1. De PHP versie van de server/hosting kan erg belangrijk zijn als jouw website gebruik maakt van PHP. Een beter geoptimaliseerde PHP versie kan ervoor zorgen dat de PHP processen beter verlopen. Dit kan resulteren in een snellere en veiligere WordPress website.

Tot 28 november wordt PHP 7.4. doorontwikkeld. Daarna stopt de ontwikkeling. Het is dus goed om hiervan bewust te zijn. Uiteindelijk moet elke site (voor de veiligheid) om naar de nieuwere PHP versie.

WordPress website omzetten naar PHP 8.0.

Nu is de oplossing in principe vrij eenvoudig. De meeste hosting partijen bieden nu al PHP 8.0 aan. Als je inlogt in je hostingpaneel kun je bij PHP opties switchen van PHP versie. Hier zie je als het goed is de optie PHP 8.0. Het kan enkele minuten duren maar daarna draait de website op PHP 8.0. Vrij eenvoudig dus. Het grotere probleem dat speelt zijn de thema’s /plugins van jouw WordPress website. Het kan namelijk zo zijn dat de ontwikkelaars van een plugin op jouw website nog niet zo ver zijn met het ontwikkelen. Oftewel, de plugin werkt niet (goed) op jouw website met PHP 8.0.

Vandaar dat het dus goed is om je WordPress website goed te onderhouden. In de loopt van de tijd zul je zien dat veel thema/plugin ontwikkelaars een update uitbrengen met WordPress 8.0 compatibility. Het is dus noodzakelijk dat elke plugin goed werkt met PHP 8.0. Anders is de kans op fouten en bugs er groot.

PHP 8 testen

We raden je aan om een staging te maken bij je hosting. Vaak kun je voor een staging de PHP versie aanpassen. Ze op de staging de PHP versie op PHP 8.0. en ga simpelweg testen. Zie en merk je geen problemen? Dan is jouw website klaar voor de nieuwe PHP versie.
Is dit niet het geval? Dan is het goed om bij de thema/plugin makers na te vragen wanneer ze PHP 8.0 gaan ondersteunen.

Nu is het niet zo dat na 28 november alle websites lager dan PHP 8.0 onveilig zijn. Zeker niet zelfs. Maar je website draait wel op een versie die de komende jaren niet meer ondersteunt zal worden. Wees hier dus wel bewust van.

Ga naar de bovenkant